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Microsoft Excel is what's known as an electronic spreadsheet program. An electronic
spreadsheet program produces a document that is equivalent to a manually prepared
accounting worksheet. Both the electronic and the accounting worksheets consist of a
grid-like matrix of rows and columns that let you organize information in an easy to
understand format.

The obvious advantages of the electronic worksheet over the paper-based accounting
worksheet are ease in editing and automation of calculations. To elaborate, electronic
spreadsheet software greatly improves your accuracy, efficiency and productivity. Once
you have prepared a worksheet, you can easily consider other options, called “what-if”
alternatives, by simply making changes and letting the spreadsheet recalculate all
entries to reflect this change. This leaves more time for decision making.

Spreadsheet Terminology

o Workbooks: Excel files are also referred to as workbooks. The Z%j
icon at the right represents an Excel file. To create a new/blank
workbook select New from the File menu in Excel.

e Worksheets: Each workbook can contain one or more grid-like worksheets.
Worksheets are separate units within a workbook. They are more than just
separate pages because each worksheet may be several printed pages.
Worksheets are comparable to chapters in a book. That is, they are individual
units within a book, they are multiple printed pages, and they all relate to the
same theme.

e Columns: The vertical portions of the worksheet grid are known as columns.
Columns are denoted by letter (e.g. A, G, AD, etc.). An Excel worksheet can
contain up to 256 columns.

e Rows: The horizontal portions of the worksheet grid are known as rows. Rows
are denoted by number (e.g. 1, 57, 1022, etc.). An Excel worksheet can contain
up to 65,536 rows.

e Cells: Cells are simply the point of intersection of a column and a row. Cells
have a unique address on the worksheet based on their column letter followed
by their row number (e.g. Al, G57, AD1022, etc.). Itis inside these cells that we
enter and store the information in our spreadsheet. Cells can contain 3 types of
information:

o Text Data: Simply put, words. They are often used as heading or entry
descriptions for the rows and columns, making the worksheet easier to
understand. Text data may contain letters or numerals.

o Numbers: Numeric information that is used for calculations, is the result
of a calculation, or is some other type of formatted data (e.g. dates or
time).

o Formulas: Used to perform calculations on or create relationships
between values in other specified cells.

Bookl,xls



The Excel Workspace

Formula Worksheet

Menu Bar Bar Toolbars Window

=101 x|

18] x|
g R
A a0

Microsoft Excel - Book
] File Edit Yiew Inser
NEES ERY 4 Be
arial -0 - B I U =

| i El

A B [ c | o

Format Tools Daty ‘Window Help

o~ - @I £ 8

B35 , W0

(1
(il
Ef
it

=

-

m
M
P

7

4 i it e v e s E R £

23 |
- T sheet) [ Rl

Ready 1] ML

Worksheet Status Bar
Tabs

The Formula Bar is of particular importance in Excel because of the information it
provides. There are two important parts of the formula bar worth noting.
e Name box: This can also be referred to as the address box. It displays the
address of the active cell (the cell in which you are working in or have selected).
o Entry area: This is the blank white space after the equals sign. This area
shows you the contents of the selected cell and lets you enter or edit
information. You will see the particular importance of this area when we discuss
working in cells.



Entering and Editing Data in Cells

To enter information in a particular cell, simply click on that cell and begin typing. To
move to any adjacent cell use the arrow keys. By default the enter button moves down
one row and the tab button moves over one column

There are 3 ways to edit content in a cell. One word of warning, when you select a cell
you are actually selecting all the contents within that cell. So if a cell has information in
it already and you click on it and begin typing, you will replace what was there. So to
edit the content without necessarily retyping it do one of the following.

e Select the cell and hit F2 (this will put the cursor into the cell)

¢ Double-click the cell (this will also put the cursor into the cell)

e Select the cell and then click inside the entry area of the formula bar

Deleting content is as simple as selecting the cell and hitting the delete key or
backspace key.

Working in Cells

Using a blank worksheet, lets see what happens as we enter information in cells. What
you should discover is that Excel formats the data in many different ways depending on
what it thinks it is, it’s length, and/or what is in the cells next to it.

1. In cell Al type The sales figures for the third quarter look promising.
What happened?

2. In cell B1 type Overlay problem
What happened to the sentence in cell A1? Click on cell A1 and notice what is in
the formula bar.

3. Incell A3 type 50000000000 (10 zeros) and hit enter
What happened? Click on cell A3 and notice what is in the formula bar.

4. In cell A5 type 250,000,000 (include the commas) and hit enter
What happened this time? Did the commas make a difference?

5. Incell A7 type 1/1/03 and hit enter
What happened?

6. In cell B7 type the fraction 1/2 and hit enter
What happened this time? Click on cell B7 and notice what is in the formula bar.

7. In cell A9 type Hello and in cell BS type 24
How is the information aligned in the two different cells?



Formatting Cells — Number, Alignment & Font

From the Format menu choose Cells to reveal the dialog box pictured below.
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From the number tab of this dialog box you can decide exactly how you would like the
numbers to look on your spreadsheet. This will help you avoid the instances that you
experienced in the exercise above. For instance, you can use the currency format to
automatically include the $ sign, commas, and 2 decimal places.

One important note here is that once you format a cell, that cell is formatted in that
manner regardless of whether you edit its contents or not. So if you make changes to
the information, you don't have to reformat the cell. If you need to remove all the
formatting on a cell (setting it back to the default) you must use the Clear option under
the Edit menu.

The alignment tab lets you choose how to align the contents of the cell. By default text
is left aligned and numbers are right aligned. You can also change the font type and
style here as well. We will revisit borders and patterns later



Performing Calculations in Excel

There are two basic ways to perform calculations in Excel — enter the formula or use a
predefined function. Regardless of which method you use, your cell entry must begin
with the equals sign ( = ). This tells Excel that you want a calculation to be performed.
At this point we will focus on entering formulas. We will revisit functions later.

Lets begin with simple arithmetic.
1. In cell D5 type the following formula: =6+10/2

2. In cell D6 type the following formula: =(6+10)/2

Notice the different answers. This is because of the rules of arithmetic order, which
Excel follows. The order that Excel follows is ~ * / + -. To alter the order, you must
use parentheses. Parentheses take precedence, meaning formulas in parentheses are
completed first starting with the innermost set.

The real power of Excel is the fact that you can write the formula using the cell address
instead of an actual number. For example, lets say that in cell D7 we want to add the
contents of cells D5 and D6 together. The formula we enter in D7 then is...

=D5+D6

Why is this so powerful? Well, change one of the values in cell D5 or D6. What
happened? When you change a cell value, the formula recalculates to reflect that
change. So you don’ t have edit the entire worksheet because of one minor change!

For this particular formula, typing it in is simple and efficient. If, however, the formula
included cells from all over the worksheet, you may want to employ a different method.
To create a formula by pointing and clicking do the following:

Select the cell where you want the formula

Enter =

Click on the cell you want to include

Enter the operator (™ */ + -)

Click on the next cell you want to include

Repeat this process as needed

Lets create a new workbook and enter the information seen below.

Spring Summer [Fall Winter Totals
Autos 100 200 350 200
SUVs 200 200 350 350
Trucks 300 350 400 250
Totals

Now, I would like you to enter 2 formulas and two only. Total the vehicles sold in the
spring and total the number of Autos sold for the year. THAT'S IT!



Cell Selection

As you have already figured out clicking on a single cell selects it. There are also
methods to select multiple cells.
o If the cells are adjacent to one another simply click and drag.
o If the cells are not adjacent, click the first cell, hold down the Control button and
click the next cell.
¢ You can select and entire column or row by clicking on its grey heading
¢ You can select the entire worksheet by clicking the grey box to the left of column
heading A and above row heading 1.

Copying, Cutting, and Pasting in Excel

These operations take some getting used to but are easy to pick up. To copy the
contents of one cell into another...
o select the cell
e click Copy from the toolbar (notice the “dancing ants” around the cell)
e select the cell where you want to copy
e click the Paste button from the toolbar (notice the dancing ants don't disappear,
why?)

The process of moving cell contents is exactly the same accept you use the Cut
button/command instead of Copy. The difference is that the dancing ants disappear
because you can only perform the action on the cell contents once. You can use the
editing functions for single cells or groups of cells.

Lets revisit the worksheet from above. Rather than enter the formula over and over in
each of the totals columns and totals rows, why don’t we just copy and paste the
formula we just wrote. Try it...

What happened to the formula when you pasted it into the other cells? Click on one of
those cells and take a look at the formula in the entry area of the formula bar. First
notice that the cell displays the result of the calculation but the formula bar displays the
formula. This is why the formula bar is so important.

Next, notice that the formula is different from that which was originally written. This is
what’s known in Excel as relative cell referencing. It is an extremely powerful
feature that must be understood. The essence of it is that Excel rewrote your formula
relative to its location on the worksheet. Excel analyzed the cells referenced in the
formula and updated them based on the formula’s new location. This saves you a ton of
work!



Functions

In the previous example we used multiple cell references to determine the total across
the different rows and down the different columns. For a small worksheet like our
example this method is fine but for larger worksheets it's not very efficient. Fortunately
there are a number of processes/formulas built-in to Excel that automate various tasks.
These are known as functions. To use a function click on the cell that you want to enter
the function into, click the Insert menu and choose Function. This launches the dialog

box pictured below. Choose the function you want to use click OK and you will be
prompted for the information needed to solve the formula.

Paste Function

Function category:

|M|:|5I: Recentli Jsed |

Function name:

_
ACO5

Financial aCosH

Cake 2 Time AOORESS

Math & Trig =1

Statistical AREAS

Lookup & Reference A5IM

Dakabase As5IMH

Text ATAN

Logical ATANZ

Infarmation | |aTanH |
ABS{number)

Returns the absoluke walue of a number, a number without its sign.

(] Cancel

)

Using a function requires entering one or more arguments. Arguments are pieces of
data used as input for the formula. They can be a single cell, several adjacent or
nonadjacent cells, and/or specific values. Commas separate multiple arguments within a
function. To identify a group of adjacent cells as an argument, start with the cell
address at the upper left, then enter the colon ( : ) followed by the cell address from the
lower right. This type of argument is known as a range. For example, the range A1:C3
includes cells A1, A2, A3, B1, B2, B3, C1, C2, and C3.

When you are finished entering the arguments the result of the formula is displayed in
the cell. When you click on that cell the function syntax is displayed in the formula bar.
It will look something like this:

=FunctionName(Arguments)



One very useful function is the SUM function, which adds a range of numbers together.
So, in the example above rather than entering all the cells individually we could use
SUM. In fact, because SUM is used so often in Excel it has it's own button on the
toolbar (circled below).
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Other popular functions include:

MIN returns the minimum value of a range of numbers

MAX returns the maximum value of a range of humbers

AVERAGE returns the average (or mean) of a range of humbers

COUNTIF  returns the number of cells within a range that meet the given criteria

Manipulating Rows and Columns

You'll be happy to know that once you layout your worksheet you're not stuck with it.
You have the ability to add new rows or columns to the worksheet and manipulate their
heights and widths respectively. Taking our previous example what if we need to add
motorcycle sales as pictured below?

Spring Summer [Fall Winter Totals
Autos 100 200 350 200 850
SUVs 200 200 350 350 1100
Trucks 300 350 400 250 1300
Motorcycle 100 75 50 25 250
Totals 700 825 1150 825

You can add a row or column by selecting a cell and using the insert menu. Rows are
inserted above the active cell using Insert > Row. Columns are added to the left of the
active cell using Insert Column. In our example if you select the cell that contains the
word Totals and click Insert > Row you will get a blank row between Trucks and Totals
in which you can add Motorcycles.

Notice what happens to your formulas when the data is added to the new row. They're
updated automatically!

Conversely you can delete an entire row or column by selecting it (using the row or
column heading) and using Edit > Delete. The delete button will only clear the contents
of the row or column; it won't delete them from the worksheet.

One other item worth noting, you can insert or delete multiple rows or columns by first
selecting multiples using their row or column headings.

Next, you may notice that Motorcycles is cut off because the column isn't wide enough.
There are a number of ways to manipulate the width of columns and the height of rows.
First, using the Format menu (pictured below) you can change the width to a numeric



value using the Width option. The value represents the number of characters that will
be visible in that cell.
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A second option is to use the AutoFit Selection command. If you select an entire column
then choose Format > AutoFit Selection the column width will be changed to the width
of the longest entry in that column.

Finally, you can modify the widths (and

heights) using the separators in the A, + = &
headings of the worksheet. Notice in the 1 Spring SUmmer
picture at the right what happens to the

mouse pointer when it is placed on the border between columns A and B. When in this
state you can click and drag to the right or left to increase or decrease the width of the
column.

These same operations can be performed on rows to change their height.

Formatting Cells — Borders & Patterns

From the Format menu choose Cells to reveal the Format Cells dialog box (pictured on
page 5). This time click on the Border tab. From here you can decide if your cells have
borders and how they will appear when the worksheet is printed. If you click on the
Patterns tab you can choose the background of the cell. The background can be a solid
color or one of a variety of subtle patterns. Borders and Patters can be applied to one
cell at a time or groups of cells. Let's make our example look like it does below.

Spring | Summer Fall Winter Totals
Autos 100 200 350 200 850
SUVs 200 200 350 350 1100
Trucks 300 350 400 250 1300
Motorcycles 100 75 50 25 250
Totals 700 825 1150 825 3500 |
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Merging Cells

One very powerful feature in Excel is the ability to combine numerous cells into one.
This is known as merging cells. In our example let’s say we would like to add a title

centered over the worksheet as pictured below.

2003 Sales Figures

Spring | Summer Fall Winter Totals
Autos 100 200 350 200 850
SUVs 200 200 350 350 1100
Trucks 300 350 400 250 1300
Motorcycles 100 75 50 25 250
Totals 700 825 1150 825 3500 |

Begin by inserting a new row at the top of the worksheet. Then, select the cells in that

row that are over the worksheet area you have been working with. Finally, click the

merge and center button (circle in the picture below) and notice what happens.
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The cells you selected are now one big cell that spans multiple columns. If you should
ever need to separate these cells you can do so by selecting Format > Cells, clicking on

the Alignment tab and un-checking Merge Cells.

Formatting a Worksheet for Output

Once a worksheet has been formatted to your liking there may come a time when you
would like to print it. There are a variety of Page Setup options to help you format your
output. Choose File > Page Setup to display the dialog box pictured at the top of the
next page. You will notice four tabs in this window. The functions of each are as

follows:

-

e Page: Here you can set the page orientation to portrait or landscape and scale
the size of the output or force Excel to print to a designated number of pages

e Margins: Here you can set the margins for the printed page and you can
choose to center the worksheet content horizontally or vertically on the page.

e Header/Footer: From this section you can choose from a number of
predefined headers and footers that include such things as the date, page
numbers, file names, etc. or you can create you own custom headers and

footers.

o Sheet: Pictured below, this section offers the most options
o Print area: Lets you designate a specific cell range to be printed. When
designated this is the only part of the worksheet that will be printed.

o Print titles: Lets you designate certain rows or columns that will be

printed on every page of the output. This is useful when you have large

worksheets that span multiple pages and have rows or columns designed

to be headings.

11
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o Print: In this area you can control how certain parts of the onscreen
work area are printed such as the Excel gridlines, the grey row and
column headings, and the comments you've added to cells.

o Page order: If a worksheet spans multiple pages across (i.e. the
worksheet is wider than one page), this section lets you decide the order
in which to print them.

Page l Margins l Header/Footer  Sheet l

Print area: || Print. ..

Print titles ; !
Prink Preview

Fows to repeat at top: |

Options. ..

Columns ko repeat at left: |
Print

[ Gridlines | Raow and column headings

| Black and white Comments: |{Nu::ne]| ﬂ
| Draft quality

Page order

{* Down, then aver

(" Ower, then down

(8] 4 Cancel

*NOTE: There is one very important thing to note about the Page Setup. The options
you set here ONLY apply to the worksheet you are working on. If a workbook has
multiple worksheets each worksheet has to be set up separately.

Working with Multiple Worksheets

Until now we have worked solely with one worksheet. However, a workbook can
contain multiple worksheets. Although in the same workbook file, each worksheet can
have its own characteristics, as exemplified above. In order to work with multiple
worksheets you have to be familiar with the worksheet tabs and navigation buttons
located in the lower left corner of the Excel workspace. By default a new workbook has
3 worksheets named Sheet 1, Sheet 2 and Sheet 3. Identify the active worksheet (or
the one you're working on) by the white worksheet tab with its name in bold.
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If you right click on the 17

worksheet tabs the context menu Insett, ..
pictured here will appear. Using 18 _

this menu you can Insert a new 19 Delste
worksheet, Delete an existing 0 Eenarme
worksheet, Rename the ol Move or Copy
worksheet, Move or Copy a =
worksheet to a different Excel 22 Select All Sheets
workbook, and Select All the 23

Sheets. Selecting all is useful if 24 G view Code

you want to format every

worksheet the same way using Sl L R‘EhEEH A Sheetz j Sheets /
Page Setup.

The navigation arrows are used to move Move or Copy el Ed

between sheets one at a time or to go to
the first or last sheet with just one click. Move selected sheets
They are especially useful when there are

. To boak:
numerous worksheets whose names won't
all fit in the viewable work area. |Eh:u:|l=;1 ﬂ
When you select Move or Copy the dialog Before sheet:
box to the right appears. In the top T
portion of the dialog box you pick where Sheets
you want the worksheet moved or copied Sheets
to. In the bottom portion you decide its {move to end)
location within the workbook you are
moving or copying to. By default the J
command is setup to move the worksheet.
If copying is what you desire you must | Create acopy

check the box next to Create a copy.

(0] Cancel |

Creating Graphs
Sometimes printed output simply isnt enough. In many instances having a “picture” of
the data may do the trick and that’s where graphs come in. Built in to Excel is a tool

known as the Chart Wizard. It guides you step by step through creating a graph. Click
the Chart Wizard button, circled on the toolbar below, to begin.

DEHa Ry |42 g v %Eﬁs%lillﬂﬂ% - @,
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In the first step you decide which type of chart to create.

Chart Wizard - Step 1 of 4 - Chart T

Standard Twpes

iChart bvpe:

iZalurnn

E Bar

|ﬁ Lire

Q@ Pie

o RY (Scatker)
‘ Area

& Doughnut
@f Radar

@ Surface

@ Bubble

Lﬁ;ﬁ_ Skock

Zuskom Types

Chart sub-kvpe:

[
al
»

=1

iZlustered Column, Compares values across
Caktegaries.,

Press and Hold to view Sample

Cancel

" Mext = Finish
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The second step in creating a chart is to select the data that you want to use for it; in
our example that includes everything but the totals row and the totals column.

Chart Wizard - Step 2 of 4 - Chart Sou

Daka Range l Series l

)

aon 7
350 17 |
300 17 |=‘
250 177 O Autas
200 17 @ EUYs
150 +7 O Trucks
jo0 4 O Makaroyels:
50 1
0 += .
Epring Eummer Fall winker
Daka range:
Series in: {* Rows
(" Columns
EJ iZancel < Back, || Mext = Finish

Notice the syntax used to identify the data range. First, the name of the sheet that the
data is located on is listed. Then an exclamation point (!) followed by the cell range.
The dollar signs ($) before the column and row entries serve a very specific purpose
We will revisit this purpose later as well as the value of understanding this syntax.
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The third step allows you to set certain chart options including its title and labels for
each of the axes.

Chart Wizard - Step 3 of 4 - Chart Dptions d

Titles l Axes l aridlines ] Legend l Data Labels | Data Table

Chart kitle:
|2003 Sales Figures : 2003 Sales Figures

Cakegory () axis;

P
|Seas-:un ' 350
300 1
, 250 1 -
| Sales 200 |3 Autos
Total=s 150 3 a0
- 1010 4 { |OTrucks
iﬂlLIE (E:I hEE | FIE | O Matareyels:
|Sales Takals| . LR
@ iZancel = Back Mext = Einish
In the final step you simply decide where to put the chart in the workbook.
Chart Wizard - Step 4 of 4 - Chart Locatior 7] x|
Place chart:
[ — |
e * asnewshest: |
N

" As obiject in: |Sheet1 ﬂ

@ iZancel | < Back | Finish

To edit or format any portion of the chart once it has been created simply right click on
it. The context menu that pops up provides you the opportunity to format that item.
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Absolute Cell Referencing

On page 7 we discussed the concept of relative cell addressing. Remember, when
formulas are copied or moved on a worksheet Excel rewrites them relative to their
location. What if you don't want Excel to rewrite the formula, is there a way to prevent
it from changing? The answer is yes.

Absolute cell referencing is a technique used to prevent the formulas from changing
when they are copied or moved. The dollar sign ($) is the key.
e If you put $ in front of both the column and row references (e.g. $A$1) neither
will change when copied or moved.
e If you put $ in front of the column reference (e.g. $A1) the column won't
change.
e If you put $ in front of the row reference (e.g. A$1) the row won't change.

The last two syntaxes are known as mixed cell references because part of the reference
is relative and part is absolute.

The dollar sign ($) can be typed in or there is a nifty trick once the cell reference has
been entered.
¢ In a blank cell type =SUM(A1
Now hit the F4 key
Notice what happens to the cell reference
Hit F4 again
Hit F4 one more time for the third option
Hit F4 to go back to the relative reference

3-Dimensional Workbooks
To this point all of our formulas and cell references have used cells on the same
worksheet. However, one very powerful features of Excel its ability to use both sheet
and cell references in cells. This gives you the ability to use data from one or more
worksheets on another worksheet. Here are some examples of what are known as 3-D
cell references.

=Sheet2!Al refers to cell Al on Sheet 2

=SUM(Sheet1!B1:C5) Adds the cells in range B1 through C5 on Sheet 1

=SUM(Sheetl:Sheet5!D7)  Adds the D7 cells from each of the 5 sheets (Sheet 1
through Sheet 5)
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