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Macromedia Dreamweaver MX is considered in some circles to be the industry standard in web
development tools. It is the market leader among like products, including Microsoft FrontPage
and Adobe GoLive. This workshop will introduce the basic features of Dreamweaver and some
basic web development concepts.

Planning Your Site

In Dreamweaver, the term site can refer either to a Web site or to a local storage location for
the documents belonging to a Web site. The usual way to set up a site is to create a folder on
your local disk that contains all the files for your site, and to create and edit documents within
that folder. You then periodically copy those files to a server that allows other people to view
via the web. This approach is better than creating and editing files on the live Web site itself
because it allows you to test changes in the local site before making them publicly viewable.
Furthermore, you can make a set of changes to the live site all at once instead of one file at a
time.

Site Structure

Organizing your site carefully from the start can save you time later on. If you start creating
documents without thinking about where in your folder hierarchy they should go, you may end
up with a huge, unwieldy folder full of files, or with related files scattered through a half-dozen
similarly named folders.

It’s a good practice to put related pages into the same folder; for example, your company’s
press releases, contact information, and job postings might all go in one folder, and your online
catalog pages in another folder. Use subfolders where necessary. It's also convenient to place
all your images in one location. This way, when you want to insert an image into a page you
know where to find it. Finally, if you use the image in multiple places on the site, you will only
need one copy.
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Designers sometimes place all of the non-HTML items to be used on a site in a folder called
assets. That folder may contain other folders - for example, an images folder, a PDF folder, and
a media folder. Finally if there aren't many assets shared among such groups, you might have a
separate Assets folder for each group of related pages on your site.

One very important note: your local site and your remote web site should have exactly the
same structure. If you create a local site using Dreamweaver and then upload everything to the
remote site, Dreamweaver ensures that the local structure is precisely duplicated in the remote
site.

Planning Site Navigation

Another area where planning pays off is navigation. As you design your site, think about the
experience you want your visitors to have.

You are here: It should always be easy for visitors to figure out where in your site they are,
and how to return to your top-level page.

Searching and indexes: On large sites, it should be easy for visitors to find any information
they want.  An index is also helpful for ADA compliance.

Feedback: Provide a way for visitors to contact the person responsible for maintenance
(webmaster) in case something is wrong with the site, and to contact other relevant people
associated with the company or the site.
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Exploring Dreamweaver

The first time you launch Dreamweaver MX 2004 in Windows it will offer you a choice of two
workspace layouts:  Designer and Coder.

Designer lets you work on pages in a WYSIWYG environment and provides a set of tools
specific to that view.  Coder lets you work in the HTML code view of a page and provides a set
of tools specific to that view.  In both environments there are options that let you view the code
and/or preview the page.  Dreamweaver on our machines is already set to the Designer
workspace layout.

In Windows, Dreamweaver provides an all-in-one-window integrated layout. In the integrated
workspace, all windows and panels are integrated into a single larger application window.  An
example of this window is pictured on the next page.

On the Macintosh, Dreamweaver provides a floating workspace layout, in which each document
is in its own individual window. Panel groups are initially docked together, but can be undocked
into their own windows. Windows "snap" automatically to each other, to the sides of the screen,
and to the Document window as you drag or resize them.
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Dreamweaver workspace elements

The Start page (not pictured above) enables you to open a recent document or create a new
document. From the Start page you can also learn more about Dreamweaver by taking a
product tour or a tutorial.

The Insert bar contains buttons for inserting various types of "objects," such as images,
tables, and layers, into a document. Each object is a piece of HTML code that enables you to
set various attributes as you insert it. For example, you can insert a table by clicking the Table
button in the Insert bar. If you prefer, you can insert objects using the Insert menu instead of
the Insert bar.

The Document toolbar contains buttons that provide options for different views of the
Document window (such as Design view and Code view), various viewing options, and some
common operations such as previewing in a browser.

The Standard toolbar (not displayed in the default workspace layout) contains buttons for
common operations from the File and Edit menus: New, Open, Save, Save All, Cut, Copy, Paste,
Undo, and Redo. To display the Standard toolbar, select View > Toolbars > Standard.
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The Document window displays the current document as you create and edit it.

The Property inspector lets you view and change a variety of properties for the selected
object or text. Each kind of object has different properties. The Property inspector is not
expanded by default in the Coder workspace layout.

The tag selector in the status bar at the bottom of the Document window shows the hierarchy
of tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all
its contents.

Panel groups are sets of related panels grouped together under one heading. To expand a
panel group, click the expander arrow at the left of the group's name; to undock a panel group,
drag the gripper at the left edge of the group's title bar.

The Files panel enables you to manage your files and folders, whether they are part of a
Dreamweaver site or on a remote server. The Files panel also enables you to access all the files
on your local disk, much like Windows Explorer (Windows) or the Finder (Macintosh).

Note: Dreamweaver provides many other panels, inspectors, and windows. To open
Dreamweaver panels, inspectors, and windows, use the Window menu. If you can't find a
panel, inspector, or window that's marked as open, select Window > Arrange Panels to neatly
lay out all open panels.

Creating a Local Site

A local site (the local storage area for your Web site's files) requires a name and a local root
folder where you plan to store all of the site's files. Create a different local site for each Web
site you work on. The local root folder of your site should be a folder you set up specifically for
that site. Don't use your disk as the site root, and don't use the Dreamweaver application
folder. Under the Windows 95/98, 2000, ME, and XP operating systems, a good place to store
your Web sites would be in the My Webs folder inside the My Documents folder. Inside My
Webs, you can create local root folders, one for each site you’re working on.

To Create a Local Site:
1. Click Dreamweaver Site… from the Create New column of the Start Page. The Site

Definition dialog box appears. If the dialog box is showing the Advanced tab, click Basic.
The Site Definition Wizard begins.

2. In the Site Name field, enter a name for the site. The site name you select will appear in
the Site window and on the Site > Manage Sites submenu. The name can be anything
you like (for example, My Web Site). Click Next to proceed.

3. The Wizard next asks if you will use a server technology. You would select Yes only if
you are planning to use any dynamic document types, such as Active Server Pages or
Java. If you are creating only a static site, select “No, I do not want to use a server
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technology”, and click Next to proceed.
4. The next screen asks how you want to work with your files. Click to select “Edit local

copies on my machine, then upload to server when ready (recommended)”.

In the text box where you’re asked where you want to store your files on your local
drive, you can enter the path to the folder where you want to store your Web site. Click
the folder icon to browse to and select the folder, or enter a path and folder name in the
text field. If the local root folder does not yet exist, create it from within the file
browsing dialog box and give it a name (for example, My Website). Click Next to
proceed.

5. The next screen asks how you will connect to your remote server. For the time being,
click on the arrow to select None from the pop-up menu, then click Next.

6. The next screen will show you a summary of your settings. Click Done to close the
Wizard.

The Files panel now shows the new local root
folder for your current site.  There is also a menu
to let you view all of your local disks and sites,
and a menu to let you select the site location you
are viewing (local, remote, or testing).

When you begin creating or adding files to your
site, they will appear in the Files panel under the
local root folder. The Files panel acts as a file
manager, allowing you to copy, paste, delete,
move, and open files as you would on a computer
desktop.

Creating and Editing HTML Documents

Now that you have a site set up, you can begin to create the documents (pages) that constitute
the site. You can create new, blank HTML documents in Dreamweaver, or you can open an
existing HTML document, regardless of how it was created. You can also create a new
document based on a template.

Note: Do not use special characters (such as é, ç, or ¥) or punctuation (such as colons,
slashes, or periods) in the names of files you intend to put on a remote server. Many servers
change these characters during upload, which will cause any links to the files to break.
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To Create a New blank HTML Document
•  Click HTML from the Create New column of the Start Page.

If you open the HTML Code inspector (click on one of the Code view buttons on the Document
toolbar), you can see that the new document isn't really completely blank—it contains HTML,
HEAD, and BODY tags to get you started. As you type in the Document window or insert
objects such as tables and images, you can leave the HTML Code inspector open and watch as
the HTML source code is created.

To open an existing HTML file
Choose from the following options:

•  Click Open from the Open a Recent Item column of the Start Page.

•  Double-click on the file in the Files panel.

Setting Page Properties

Page titles, background images and colors, text and link colors, and margins are among some
of the basic properties of HTML documents.  Click on the Page Properties button in the Property
inspector or select Modify > Page Properties from the menu to reveal the dialog box pictured
below.
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Appearance:

Page font: sets the default font for the entire page

Size: sets the default font size for the entire page

Text color: sets the default color of the text for the entire page

Background color: allows you to set a default page color

Background image: allows you to set an image as the background for a page

Left, Right, Top, and Bottom margin: specify the sizes of page margins in the body tag.
For best cross-browser results, provide margin values for all four margin values instead of
just two. To ensure that no margins appear, set all four values to 0.

Links:

Link font: sets the default font for text links that appear on the page.

Link size: sets the default font size for text links that appear on the page.

Link color: sets the default color for text links that appear on the page.

Rollover link: sets the default color for text links that appear on the page when the mouse
is positioned over them.

Visited link: sets the default color for text links on the page that have been visited.

Underline style: sets how text links will be (or not be) underlined on the page

Headings:

Heading font: sets the default font used for the various heading formats options available
on the page.

Heading 1 – 6: sets the size and color for each the six different heading options available
on the page.

Title/Encoding:

Title: specifies the page title that appears in the title bar of the browser window.

Encoding: specifies the encoding used for characters in the document. Choose Western
(Latin 1) for English and Western European languages.




















































